一、交换机的基本配置
三、生成树协议配置
生成树协议(STP)的目的是在实现交换机之间冗余连接的同时,避免网络环路的出现,实现网络的高可靠性。当交换机之间有多个VLAN时Trunk线路负载会过重,这时需要设置多个Trunk端口,但这样会形成网络环路,而STP协议便可以解决这一问题。
(2) IPv6静态路由设置
R1: E0(2005:CCCC::1/64) S0(2007:CCCC::1/64)
R2: E0(2004:CCCC::1/64) S0(2007:CCCC::2/64)
PC1: IP 2005:CCCC::2/64 网关 2005:CCCC::1
PC2: IP 2004:CCCC::2/64 网关 2004:CCCC::1
R1相关配置如下。
Router#
Router#configure terminal
Router(config)#hostname R1
R1(config)#ipv6 unicast-routing (开启IPv6单播路由)
R1(config)#interface f0/0
R1()config-if)#ipv6 address 2005:CCCC::1/64 (设置E0口IPv6地址)
R1(config-if)#no shut
R1(config-if)#exit
R1(config)#interface Serial0/2/0
R1(config-if)#ipv6 address 2007:CCCC::1/64 (设置S0口IPv6地址)
R1(config-if)#clock rate 128000 (配置S0口时钟频率)
R1(config-if)#exit
R1(config)#ipv6 route 2004:CCCC::/64 Serial0/2/0 (设置IPv6静态地址)
R2相关配置如下。
Router#
Router#configure terminal
Router(config)#hostname R2
R2(config)#ipv6 unicast-routing (开启IPv6单播路由)
R2(config)#interface f0/0
R2(config-if)#ipv6 address 2004:CCCC::1/64 (设置E0口IPv6地址)
R2(config-if)#no shut
R2(config-if)#exit
R2(config)#interface Serial0/2/0
R2(config-if)#ipv6 address 2007:CCCC::2/64 (设置S0口IPv6地址)
R2(config-if)#clock rate 128000 (配置S0口时钟频率)
R2(config-if)#exit
R2(config)#ipv6 route 2005:CCCC::/64 Serial0/2/0 (设置IPv6静态路由)
配置完成后,在R1中查看IPv6路由表如下。
R1#show ipv6 interface (内容省略)
五、配置路由协议
IP路由选择协议用有效的、无循环的路由信息填充路由表,从而为数据包在网络之间传递提供了可靠的路径信息。路由选择协议又分为距离矢量、链路状态和平衡混合三种。
距离矢量(Distance Vector)路由协议计算网络中所有链路的矢量和距离并以此为依据确认最佳路径。使用距离矢量路由协议的路由器定期向其相邻的路由器发送全部或部分路由表。典型的距离矢量路由协议有RIP和IGRP。
链路状态(Link State)路由协议使用为每个路由器创建的拓扑数据库来创建路由表,每个路由器通过此数据库建立一个整个网络的拓扑图。在拓扑图的基础上通过相应的路由算法计算出通往各目标网段的最佳路径,并最终形成路由表。典型的链路状态路由协议是OSPF(Open Shortest Path First,开放最短路径优先)路由协议。
平衡混合(Balanced Hybrid)路由协议结合了链路状态和距离矢量两种协议的优点,此类协议的代表是EIGRP,即增强型内部网关协议。
RIP相关命令
命令 功能
router rip 指定使用RIP协议
version{1|2} 指定RIP版本
network network 指定与该路由器相连的网络
show ip route 查看路由表信息
show ip route rip 查看RIP协议路由信息
各接口IP地址分配如下。
R1 E0 192.168.1.1
R1 S0 192.168.65.1
R1 S1 192.168.67.1
R2 E0 192.168.3.1
R2 S0 192.168.65.2
R2 S1 192.168.69.1
R3 E0 192.168.5.1
R3 S0 192.168.69.2
R3 S1 192.168.67.2
根据要求配置各路由器的各接口地址
R1#config t
R1(config)#no logging console (不在控制台接口显示log提示信息)
R1(config)#interface fastethernet0/1
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface serial 0
R1(config-if)#ip address 192.168.65.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface serial 1
R1(config-if)#ip address 192.168.67.1 255.255.255.0
R1(config-if)#no shutdown
在全局配置模式下使用no logging console配置命令,可以防止大量的端口状态变化信息和报警信息对配置过程的影响。类似配置R1各接口地址的方法可以配置好路由器R2和R3的各接口地址。
用show ip route命令查看路由表信息
R1#show ip route
配置路由器R1
R1(config)#ip routing (允许路由选择协议)
R1(config)#router rip (进入rip协议配置子模式)
R1(config-router)#network 192.168.1.0 (声明网络192.168.1.0/24)
R1(config-router)#network 192.168.65.0
R1(config-router)#network 192.168.67.0
R1(config-router)#version 2 (设置RIP协议版本2)
R1(config-router)#exit
配置路由器R2
R2(config)#ip routing
R2(config)#router rip (进入RIP协议配置子模式)
R2(config-router)#network 192.168.3.0 (声明网络192.168.3.0/24)
R2(config-router)#netword 192.168.65.0
R2(config-router)#network 192.168.69.0
R2(config-router)#version 2 (设置RIP协议版本2)
R2(config-router)#exit
配置路由器R3
R3(config)#ip routing
R3(config)#router rip (进入RIP协议配置子模式)
R3(config-router)#network 192.168.5.0 (声明网络192.168.5.0/24)
R3(config-router)#network 192.168.67.0
R3(config-router)#network 192.168.69.0
R3(config-router)#version 2 (设置RIP协议版本2)
R3(config-router)#exit
2. 配置IGRP协议
内部网关路由协议(Interior Gateway Routing Protocol,IGRP)是一种动态距离向量路由协议,它不支持VLSM和不连续的子网。
默认情况下,IGRP每90s发送一次路由更新广播,在3个更新周期内(即270s)没有从路由表中的一个路由器接收到更新,则宣布路由不可访问。在7个更新周期(即360s)后,IOS软件从路由表中清除路由。
IGRP相关命令
命令 功能
router igrp autonomous-system 指定使用IGRP协议
network network 指定与该路由器相连的网络
show ip route 查看路由表信息
show ip route igrp 查看IGRP协议路由信息
查看R1、R2、R3的配置清单
R1#show running-config
R2#show running-config
R3#show running-config
查看三个路由器的路由表
R1#show ip route igrp
R2#show ip route igrp
R3#show ip route igrp
3. 配置OSPF协议
开放最短路径优先(OSPF)协议是一种链路状态路由选择协议。链路是路由器接口的另一种说法,因此OSPF也称为接口状态路由协议。OSPF通过路由器之间通告网络接口的状态来建立链路状态数据库,生成最短路径树,每个OSPF路由器使用这些最短路径构造路由表。
OSPF相关命令
命令 功能
router ospf process-id 指定使用OSPF协议
network address wildcard-mask area area-id 指定与该路由器相连的网络
show ip route 查看路由表信息
show ip route ospf 查看OSPF协议路由信息
注:1. OSPF路由进程process-id需要指定范围在1-65535之间。
2. wildcard-mask是子网掩码的反码,网络区域ID area-id 是在0-4294967295内的十进制数,
也可以带有IP地址格式的x.x.x.x。当网络区域ID为0时为主干域。不同网络区域的路由器通过主干域学习路由信息。
按照设计图所示的网络拓扑结构图来配置OSPF协议。
R1:
interface Ethernet 0
ip address 192.1.0.129 255.255.255.192
Interface serial 0
ip address 192.200.10.5 255.255.255.252
router ospf 100
network 192.200.10.4 0.0.0.3 area 0
network 192.1.0.128 0.0.0.63 area 1
R2:
interface Ethernet 0
ip address 192.1.0.65 255.255.255.192
interface serial 0
ip address 192.200.10.6 255.255.255.252
router ospf 200
network 192.200.10.4 0.0.0.3 area 0
network 192.1.0.64 0.0.0.63 area 2
R3:
interface ethernet 0
ip address 192.1.0.130 255.255.255.192
router ospf 300
network 192.1.0.128 0.0.0.63 area 1
R4:
interface Ethernet 0
ip address 192.1.0.66 255.255.255.192
router ospf 400
network 192.1.0.64 0.0.0.63 area 1
用以下命令来调试或查看配置信息和路由信息。
debug ip ospf events
debug ip ospf packet
show ip ospf
show ip ospf database
show ip ospf interface
show ip ospf neighbor
show ip route
下面给出各路由器的配置清单,清单中只列出其中重要的配置信息。
R1#show running-config
Interface Serial0
Ip address 192.200.10.1 255.255.255.252
Interface Ethernet0
Ip address 10.20.10.1 255.255.255.255
router eigrp 200
network 192.200.10.0 0.0.0.3
network 10.20.10.0 0.0.0.255
no auto-summary
R2#show running-config
Interface Serial0
Ip address 192.200.10.2 255.255.255.252
Interface Ethernet0
Ip address 201.10.10.1 255.255.255.255
router eigrp 200
network 192.200.10.0 0.0.0.3
network 201.10.10.0
no auto-summary
连接好线路后,就可以进行配置工作。
R1#config t
R1(config)#isdn switch-type ?
(查看交换机类型,在中国使用basic-net3类型的最多)
配置R1:
R1(config)#isdn switch-type basic-net3 (设置交换机类型为basic-net3)
R1(config)#interface bri0 (进入BRI接口配置模式)
R1(config-if)#ip address 192.168.1.1 255.255.255.0 (设置接口IP地址)
R1(config-if)#encapsulation ppp (设置封装协议为ppp)
R1(config-if)#dialer string 80000002 (设置拨号串,R2的ISDN号码)
R1(config-if)#dialer-group 1 (设置拨号组号为1,把BRI0接口与拨号列表1相关联)
R1(config-if)#no shutdown (激活接口)
R1(config-if)#exit
R1(config)#dialer-list 1protocol ip permit (设置拨号列表1)
R1(config)#end
R1#
其中dialer-list 1 protocol ip permit允许IP协议包成为引起拨号的“感兴趣包”,即当有IP包需要在拨号线路上传送时可以引起拨号。
配置R2:
R2(config)#isdn switch-type basic-net3 (设置交换机类型为basic-net3)
R2(config)#interface bri0 (进入BRI接口配置模式)
R2(config-if)#ip address 192.168.1.2 255.255.255.0 (设置接口IP地址)
R2(config-if)#encapsulation ppp (设置封装协议为ppp)
R2(config-if)#dialer string 80000001 (设置拨号串,R1的ISDN号码)
R2(config-if)#dialer-group 1 (设置拨号组号为1,把BRI0接口与拨号列表1相关联)
R2(config-if)#no shutdown (激活端口)
R2(config-if)#exit
R2(config)#dialer-list 1 protocol ip permit (设置拨号列表1)
R2(config)#end
R2#
配置完成后,可以使用debug和ping命令来调试配置结果。
R1(config)#logging console (在终端上显示监测信息)
R1(config)#exit
R1#debug dialer (监测dialer信息)
Dial on demand events debugging is on
R1#ping 192.168.1.2 (内容省略…)
R1#undebug all (关闭所有调试信息)
还可以用show isdn status命令查看ISDN状态,用show dialer命令显示当前的拨号及其配置等信息。
(1) 配置基本的帧中继连接。
路由器R1:
R1#config t
R1(config)#interface E0
R1(config-if)#ip address 192.1.1.1 255.255.255.0
R1(config-if)#no keepalive
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface s0
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#encap frame-relay (该接口使用帧中继封装格式)
R1(config-if)#no shutdown
R1(config-if)#no frame-relay inverse-arp (关闭帧中继逆向ARP)
R1(config-if)#frame map ip 192.168.1.2 cisco
R1(config-if)#end
R1#
路由器R2:
R2#config t
R2(config)#interface E0
R2(config-if)#ip address 192.1.2.1 255.255.255.0
R2(config-if)#no keepalive
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#interface s0
R2(config-if)#ip address 192.168.1.2 255.255.255.0
R2(config-if)#encap frame-relay (该接口使用帧中继封装格式)
R2(config-if)#no shutdown
R2(config-if)#no frame-relay inverse-arp (关闭帧中继逆向ARP)
R2(config-if)#frame map ip 192.168.1.1 cisco
R2(config-if)#end
R2#
配置完成后可以用下面的命令查看帧中继相关信息。
show frame pvc
show frame map
show frame traffic
show frame lmi
版权说明:如非注明,本站文章均为 扬州驻场服务-网络设备调试-监控维修-南京泽同信息科技有限公司 原创,转载请注明出处和附带本文链接。
请在这里放置你的在线分享代码